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CHAPTER 8

SING MACROS TO
EDIT

In this chapter you'll learn about

{18

Recording a Macro

(]

Playing a Macro
L Editing a Macro
U Creating a Macro

Macros help you automate word processing tasks. They can be used to type fre-
quently used text or to execute a sequence of commands. You create a macro
by recording and saving your keystrokes. When you play the macro, the
keystrokes that you recorded are carried out. You can edit the macros to cor-
rect any errors or customize them.

REcorpING A MACRO

When you record a macro, WordStar captures and saves the keystrokes in a
macro file. When you press the hot key you assign to the macro, the macro
executes the keystrokes that you saved.
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Follow the steps below to record a macro that saves the current file, opens a
window on another file, and sizes the window. You'll call the macro
“Window.”

1 Choose File=>Open Document (F,D) and name the file MACRO.DOC.

2 Type the sample text below:

WordStar stores each macro as a file, with the name you
gave it while recording or editing and the .WSM extension.

3 Choose Utilities=>Macros=>Record (Alt+U,M,R) to record a macro.

The Record Macro dialog box appears.

Record Macro

Macro Nane: [N Hot. Key: I
Description: [ ERETT

To stop recording, press Alt+=

Macro: Hot Keys:

IlIIIIIIIIIIlIlIIIIllIIIIlllllIIllIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII‘

4 In the Macro Name box, type window.

Note: When you name a macro, use a name that will help you identify it.
You can use up to eight characters. WordStar assigns the .WSM extension
to the filename.

5 Press the Tab key.
The cursor moves to the Hot Key box. Now you’ll assign the single key or
combination of keys for running the macro. For more information about hot
key assignments, see the Reference manual.

6 Press the Down Arrow to choose a hot key from the list of available hot keys.

7 In the Hot Key list, move the cursor to Alt+W and press Enter.
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RECORDING A MACRO

Alt+W appears in the Hot Key box and the cursor moves to the Description
box.

In the Description box, type a description of the macro. Type Save
file-Open window-Size window.

You can use as many as 48 characters, including spaces, for a macro
description.

Now that you’ve named and described the macro, you’re ready to record
the keystrokes.

Press F10 or choose OK to begin recording keystrokes.

(Ignore the End Recording message at the top of the screen.)

Now you'll record the following sequence of keystrokes for the macro:

1

2

Press Alt+F,S to save the file MACRO.DOC.

Press Alt+F,W to open a window on a second file.

The Open Document dialog box appears.

Press Alt+Hyphen (hold down the Alt key while you press the hyphen key)
to insert a pause for input command into the macro. When you play back
the macro later, the macro will pause while you enter a filename.

Type REVIEW.DOC for the second filename.

Press Alt+hyphen to end the pause for input.

The macro resumes recording.

Press F10 or choose OK to open REVIEW.DOC.

Press Alt+V,W to size the window.

In the Change Window Size dialog box, press F to make each window use
the full screen. Press F10 or choose OK to close the dialog box.

Each window now uses the full screen.
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9  Press Alt+Equal (hold down the Alt key while you press the Equal key) to
stop recording.

10 Close and abandon REVIEW.DOC. Then close and abandon MACRO.DOC.

You now have a macro that saves a file, opens a second window, and sizes the
window to fill the entire screen.

P1avING A MACRO

When you play a macro, the commands recorded in the macro are carried out.
You can play a macro by using a menu command or the assigned hot key. In
the following section, you'll play the WINDOW macro by using the hot key

you assigned.
17 Open the MACRO.DOC file.

2 Press Alt+W to play the WINDOW macro. When the Open Document
dialog box appears, the macro pauses for input.

3 Type a filename for the second window and press Alt+Hyphen to end the
pause for input. The second window is opened and sized.

4  Close and abandon both files.

EpITING A MACRO

After you record a macro, you may want to change it. WordStar has a macro
language that you can use to edit a macro.

Follow these steps to edit a macro:
7 Atthe Opening screen, choose Ultilities=Macros=>Edit/Create (U,M,E).

The Edit/Create Macro dialog box appears.
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2 In the Macro Name box, type window.
3 Press F10 or choose OK to edit the macro.
The WINDOW macro (WINDOW.WSM) is opened.
In every macro file, you'll see the command “Sub MAIN”" which is a subroutine.
A subroutine is a collection of statements that are invoked by the Sub com-

mand. Each macro must contain the Sub MAIN subroutine.

Subroutines usually contain key functions. A key function tells the macro
which keys to play back. The format for a key function is:

Key (“key stroke string”)
In the Window macro, you'll see these key functions near the end of the file.

KEY (”“{F10}{Alt+V}iw")
KEY (“f")

The first key function above displays the Change Window Size dialog box. The
second key function changes the window size to full screen.

In the following steps, you’ll put a comment at the beginning of the
WINDOW.WSM file to provide descriptive information about the macro. A
comment is a statement for you to read but is not a command for the macro to
execute.
1 Atthe beginning of line 1, type this text:

rem Saves current file, opens and sizes second window.

2  Press Enter.

In the following steps, you’ll change a key function so that the window takes up
only five lines instead of the full screen.
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The key function looks like this:

KEY (“f")
Move the cursor to the “f” in the key function.
Delete the “f” and type L5.
Choose File=>Save and Close (Alt+F,L) to save the macro.

Open a file and the WINDOW macro to see the changes you just made. (If
you need help, see “Playing a Macro” in this chapter.)

If WordStar finds errors, it returns you to the macro file to correct them.

CREATING A MACRO WITH THE MACRO LANGUAGE

In this chapter, you’ve created a macro by recording your keystrokes. Now
you'll create a macro using the macro language.

In the following steps, you’ll create a macro that runs a spelling check, saves
your document, and then runs Preview.

1

2

At the Opening screen, choose Utilities=Macros=>Edit/Create (U,M,E).

Assign a macro name, for example, SPELL. WordStar gives the file a .WSM
extension.

Assign a hot key such as Alt+3 and type a description.
Press F10 or choose OK to open the macro.

WordStar opens the new macro.

On line 1, type this text:

rem Runs spelling check, saves file, runs Preview.

Press Enter.
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7 Type Sub MAIN and press Enter. This marks the beginning of the main

subroutine.

On the next two lines, type the sample statements shown below. (You can
type these statements in all lowercase; the case used below is for readability
only.)
Note: “AutoRestore(ON)” is an example of a statement. When there is
more than one statement on a line, the statements must be separated by
colons. When you type statements, separate them with a space, a colon,
and another space.

AutoRestore (ON) : SetHelpLevel(4) : Insert (ON)

CmdTags (OFF) : HideDots(ON) : ColMode (OFF)

ColReplace (OFF)
Press Enter.
The statements establish these settings:
AutoRestore(ON) Restores original settings after the macro plays.

SetHelpLevel(4) Sets the help level at 4.

Insert(ON) Allows characters to be inserted into existing text instead of
overwriting text.

CmdTags(OFF) Turns off the display of command tags.
HideDots(ON) Turns off the display of dot commands.

ColMode(OFF) Turns column mode off. This is the default for marking
blocks.

ColReplace(OFF) Turns off column replace. This is the default for moving
and copying blocks.
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In the following steps, you'll type two key functions and some exception
conditions:

The first key function that you'll type is:
Key (" {Alt+U}S")

1 Type Key(” to begin the Key function. Every Key function begins with
(” and ends with ”).

2 Type {Alt+U}S to move the cursor to the beginning of the file and start the
spelling check.

3 Type”) to end the function. Press Enter to move to the next line. Press the
Tab key to indent the line.

4 Type IfException and press Enter.
When a spelling check is complete, WordStar displays a message giving the
word count. This is an exception condition. When a macro encounters an
exception condition, you can have the macro pause while you provide
required input or you can tell the macro to provide the input. To have the
macro provide input, you add an IfException clause to your macro
statement. In the following steps, you tell the macro to issue an Escape
when the word count message is displayed.

5 On the next line under “IfException” type ACK: Key(”{Esc}”) and press Enter.

The ACK clause issues an Escape key command when the spelling check
message appears.

6 To end the IfException clause type End IfException and press Enter.
7 Type Key(”{Alt+F}S”) and press Enter. This key function saves the file.

8 Type Key(”{Alt+V}P”) and press Enter. This key function runs Preview.
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9 Type End Sub to end the subroutine and press Enter.
When your macro is finished, it will look like this:

rem Runs spelling check, saves file, runs Preview
Sub MAIN
AutoRestore (ON) : SetHelpLevel(4) : Insert (ON)
CmdTags (OFF)
HideDots (ON) : ColMode(OFF) : ColReplace (OFF)
Key (“{Alt+U}S")
IfException
ACK: Key (“{Esc}”)
End IfException
Key (“{Alt+F}S")
Key (“{Alt+V}P")
End Sub

10 Save the macro and then play it in a document.
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MACROS Pull-down: ALT + UM
Classic: "M

Records, creates, edits, or runs a macro that enters a longer series of text and
commands.

The WordStar macro capabilities allow you to use a few keystrokes to enter a
series of keystrokes and commands. For example, you can create a macro so
that each time you type Alt+W, the word “WordStar” is inserted in your text.
Or a macro can change the order of two words (mark the first word as a block,
move the cursor to the end of the next word, and move the block).

When you choose Macros, the following menu appears.

Record. .. MR
Edit/Create... "MD
Single Step... “MS

Copy... “MO
Delete... “MY
Rename. . . “ME

You can create a macro in either of two ways:

s Use Record, or the AMR classic command, to record keystrokes. This is the
easier way to create a macro. WordStar records commands and keystrokes
as you enter them. When you are finished, WordStar compiles them into a
macro file that contains all the appropriate macro commands.

= Use Edit/Create, or the AMD classic command, to enter macro commands
into a file that you edit like a nondocument. To use this command, you
need to know the WordStar macro language. This language allows you to
create macros that are too complex to record with the Record command.
For example, you can have a macro repeat a certain action as many times as
needed each time you run the macro. The example in “The Macro
Language” in this section enters a bullet character and waits for you to type
text, then repeats that sequence after the end of each paragraph; the macro
stops and returns you to editing when you finish your bulleted list.

12 -21
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If you need to write a macro that is too complex to record, you can first record
a simpler macro that contains commands and keystrokes that can be recorded,
then use Edit/Create to add the macro language for the rest of the macro. You
can also copy a macro and edit it to create a similar one, and you can copy
blocks of macro commands from one macro file to another.

After you create a macro, you can use Single Step, or the AMS classic com-
mand, to play it back step by step to identify any problems.

To execute a macro, you can either use a hot key, or use Play, or the

AMP classic command. You can stop the macro by pressing Esc or ABreak.
(When a macro is paused for input, you must use *Break.) You can change
the Esc keystroke or add another key to stop a macro in WSCHANGE (DCDC
and DCDD).

You can also copy, rename, and delete macros using commands on the
Macros menu.

TIP You can set up a macro to run a series of commands that you frequently
use when you start WordStar. Then you can run the macro immediately when
you start WordStar by typing ws /mmacroname. For example, you can set up a
macro named LETTER to change to the C:\CUSTOMER directory, open a new
file, and read in a file of boilerplate text and formatting. Then, any time you
want to start WordStar and start a new letter, type ws /mletter. If you want to
start WordStar, open a file, and then run a macro, type the filename before the
/m option.

WORKING WITH MACROS

12-22

MACRO HOT KEYS

You can execute a macro by pressing a single key or key combination called a
hot key. You can assign a hot key to a macro when you create it. Eighty-two
hot keys are available:

= The function keys F2 through F9, and F11 and F12. (F1 and F10 are reserved
for help and closing dialog boxes.)

® The function keys F1 through F12 combined with the Shift key.

® The function keys F1 through F12 combined with the Ctrl key.
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= The function keys F1 through F12 combined with the Alt key.
= The Alt key combined with the letters A-Z and the digits 0-9.
Keep these points in mind about macro hot keys:

= The Alt key combined with the letters F, E, V, I, S, L, U, and H access the
WordStar pull-down menus. If you use any of these keystrokes as hot keys,
you can’t use them for those menus. (You can still display the menus using a
mouse or using the Right and Left Arrow keys in the menu bar.)

= You don’t have to assign a hot key to each macro. If a macro is not assigned
a hot key, you can run the macro using Macros=>Play (or the AMP classic
command).

= |f you want to assign a hot key to a macro that doesn’t have one, or change
the hot key assigned to a macro, use Macros=>Rename, or AME. Don’t use
Macros=>Record (*"MR); it will erase the macro and create a new one.

= WordStar comes with predefined macros for the function key hot keys and
several other hot keys. These macros are listed in Appendix D, “Function
Keys and Other Macros.” You can define new macros for these keys if you
want, using Record (*MR) or Edit/Create ("MD).

MACRO FILES AND DIRECTORIES

Each macro is stored as a file, with the name you gave it while recording or
editing and the .WSM extension.

CAUTION When you record, create, or edit a macro and save it,
WordStar compiles the macro, adding executable code. Macro files appear to
be nondocuments (ASCII files) when you edit them, but they contain other
information. You must edit them with Macros=>Create/Edit (or "MD) to get
usable macros.

On most systems, all the macro files are stored in one directory. The default

macro directory name is WS\MACROS; you can change it with WSCHANGE
(CD2Q).
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Piay

Pull-down: ALT + U, M, P
Classic: "MP

Executes a macro.

You can execute a macro either using a hot key or using this command. For an
explanation on using hot keys, see “Macro Hot Keys” in this section.

Follow these steps to play a macro:
1 Choose Utilities=>Macros=>Play, or use the AMP classic command.

2 |n the Play Macro dialog box, specify the macro to play. You can choose
the macro either by name or hot key. When you press the Down Arrow key
and scroll through the list of macros, the description for the highlighted
macro appears in the dialog box.

3 Press F10 or choose OK.

WordStar executes all the commands and enters all the text specified in the
macro. Generally, menus and dialog boxes are not displayed unless you need
to enter input.

You can stop the macro by pressing Esc or ABreak. (When a macro is paused
for input, you must use ~Break.)

REcorD Pull-down: ALT + U, M, R

12-24

Classic: "MR

Records a series of keystrokes and stores them as a macro that you can
execute.

You can create a macro by choosing Record and then pressing all the
keystrokes that you want in the macro. Follow these steps:

1 Choose Utilities=>Macros=>Record, or use the AMR classic command.
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2 In the Record Macro dialog box, type the name you want to give the macro.
If the macro name is already in use, confirm that you want to redefine the
macro or give it another name.

3 Specify the hot key that will execute the macro. You can press the Down
Arrow key and scroll through the list to see which hot keys are available. If
the hot key you specify is already in use, confirm that you want to reassign
the hot key or specify another hot key. If you don’t want to assign a hot key
to the macro, you can skip this step.

4 Type a description of the macro to remind you what it does and help you
find it in the list. The description can be up to 48 characters long. If you
don’t want to give a description for the macro, you can skip this step.

5 Press F10 or choose OK.

6 Enter all the keystrokes you want in the macro. Enter them in the same way
you want them played back when you run the macro.

You may need the macro to pause when you run it so that you can enter
information such as a filename. At any place you want the macro to pause,
press Alt+Hyphen. Then type any number of keystrokes as an example of
the input. Press Alt+Hyphen again to end the pause, and continue entering
the macro keystrokes. When you execute the macro, it pauses at that point
for input and continues after you press Alt+Hyphen. (You can change the
Alt+Hyphen keystroke to another keystroke using WSCHANGE (DCDB).)

Note: Mouse actions and clicks are not recorded in macros and do not
work while you are recording a macro; you must use the keyboard.

7 When you finish entering the keystrokes, press Alt+= (hold down the Alt key
and press =). (You can change the Alt+= keystroke to another keystroke
using WSCHANGE (DCDA).)

WordStar records and compiles the macro. If you want to make adjustments to

the macro, you can either record it again or edit it using Macros=>Edit/Create,
or the AMD classic command.
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EDIT/CREATE Pull-down: ALT + U, M, E
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Classic: "MD

Creates and modifies a macro that contains keystrokes and commands that
you enter.

Each macro consists of a series of WordStar commands and functions. You edit
a macro using the same commands you use for editing a nondocument file.
Follow these steps:

Note: You cannot edit a macro if you already have two editing windows open.

1

2

Choose Utilities=>Macros=>Edit/Create, or use the AMD classic command.
In the Edit/Create Macro dialog box, specify the macro name.

When you press the Down Arrow key and scroll through the list of macros,
the description for the highlighted macro appears in the dialog box.

If you're creating a new macro, specify the hot key that will execute the
macro. You can press the Down Arrow key and scroll through the list to see
which hot keys are available. If the hot key you specify is already in use,
confirm that you want to reassign the hot key or specify another hot key. If
you don’t want to assign a hot key to the macro, you can skip this step.

Type a description of the macro to remind you of what it does and to help
you find it in the list. The description can be up to 48 characters long. If
you don’t want to give a description for the macro, you can skip this step.

Press F10 or choose OK. WordStar opens a full-screen editing window for
the macro.

Type the text of the macro or make any editing changes. For information
about what you can enter, see “The Macro Language” in this section. When
you edit a macro, you can use the commands used for editing
nondocuments.

TIP  You may want to periodically use File=>Save ("KS) to save your
changes while editing.
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7 When you finish, save the macro using File=>Save and Close (*KD).

WordStar compiles the macro. If it finds any syntax errors or other errors, they
are entered into the macro file. You must edit the macro again to correct the
errors.

Errors in a macro file are noted by a message describing the error, followed by
the line of the macro that contains the error, with a caret () below the line
pointing to the location of the error.

TIP The Alt+D hot key is preassigned to a macro that goes to the next error
message in a macro file. This is helpful when you edit macros to fix errors.

If you want to copy a block of text from one macro into another, start from the
Opening screen rather than the Editing screen. Choose Macros=>Edit/Create
(or AMD), and then choose File=Open/Switch (or 2OK). Then copy the block
between the windows in the same way you would while editing a document.

SINGLE STEP Pull-down: ALT + U, M, S
Classic: "MS

Plays back a macro one step at a time to locate errors.

After you create or edit a macro, you can play it back step by step to identify

any problems. This command is helpful when a macro doesn’t work exactly as

you expect it to. Follow these steps:

1 Choose Utilities=Macros=>Single Step, or use the AMS classic command.

2 In the Single Step dialog box, specify the macro to play. You can specify the
macro either by name or by hot key. When you press the Down Arrow key
and scroll through the list of macros, the description for the highlighted
macro appears in the dialog box.

3 Press F10 or choose OK.

WordStar executes the first command or keystroke in the macro, and pauses.
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Copry
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4 Press the Spacebar to continue to the next command, function, or keystroke.
Continue in this manner until the macro finishes. You can stop running the
macro by pressing Esc or ABreak. (When a macro is paused for input, you
must use ~Break.)

Pull-down: ALT + U, M , C
Classic: "MO
Copies a macro.

If you want to create a macro similar to another one, you can copy the first
macro and edit the copy. You can also make copies of macros so that several
people can use them on their computers. Follow these steps:

1

2

4

Choose Utilities=»Macros=>Copy, or use the AMO classic command.

In the Copy Macro dialog box, specify the macro to copy.

You can specify the macro either by name or by hot key. When you press
the Down Arrow key and scroll through the list of macros, the description
for the highlighted macro appears in the dialog box.

Specify the macro name for the new copy. Type the path with the name if
necessary. If the name is already in use, confirm that you want to overwrite

the current macro.

Press F10 or choose OK to copy the macro.

The copied macro has the same description as the original, but is not assigned a
hot key. You can assign a hot key and description when you edit the macro, or
you can use Rename Macro (or the AME classic command).
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DELETE Pull-down: ALT + U, M, D
Classic: "MY

Deletes a macro.

Follow these steps to delete a macro:

1 Choose Utilities=>Macros=>Delete, or use the AMY classic command.

2 In the Delete Macro dialog box, specify the macro to delete. You can
specify the macro either by name or by hot key. When you press the
Down Arrow key and scroll through the list of macros, the description for

the highlighted macro appears in the dialog box.

3 Press F10 or choose OK to delete the macro, and confirm the deletion.

RENAME Pull-down: ALT + U, M, N
Classicc: "ME

Renames a macro.

You can use this command to rename a macro, assign a new hot key, or add or
edit a description. Follow these steps:

1 Choose Utilities=>Macros=>Rename, or use the AME classic command.

2 In the Rename Macro dialog box, specify the macro to rename. You can
specify the macro either by name or by hot key. When you press the
Down Arrow key and scroll through the list of macros, the description for
the highlighted macro appears in the dialog box.

3 Specify the new macro name, hot key, and/or description. If the name or
hot key is already in use, confirm that you want to overwrite the current
assignment.

4 Press F10 or choose OK to rename the macro.
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THE MACRO LANGUAGE
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WordStar macros are written and recorded in a BASIC-like language.

Each macro consists of one or more subroutines. A subroutine is a series of
statements. The MAIN subroutine is required, and you can use as many other
subroutines as you like.

Each statement is a command or function and, if required, its arguments. A
statement can have a modifying clause. Each statement can have a label to
identify it.

Commands generally control the flow of execution, by specifying which
statement to execute next. Some commands are Call, GoTo, Return, Stop,
and PlayMacro.

Functions perform specific tasks. Some functions are Key, SetHelpLevel, Insert,
and PauseForlnput. The Key function is the most important function because it
supplies keystrokes to WordStar as if they were typed at the keyboard.

The macro language is described in detail in the following sections. To see
more examples, you can look at the macro files that came with WordStar.
Unless you’ve changed directory names, they are in the \WS\MACROS direc-
tory. These macros are for the function keys and several other hot keys, and
are listed in Appendix D.

MACRO STRUCTURE

A very simple macro is shown below.

Sub MAIN
Key ("Good morning! {Enter}")
End Sub

This macro types Good morning! into a document and starts a new line. The
macro has three lines. The first line says that the subroutine MAIN begins here,
and the last line ends the subroutine.
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The second line in the macro is a statement that consists of a single Key( ) func-
tion and its argument, the keystroke string Good morning!{Enter}. Arguments
for functions are always enclosed in parentheses. Keystroke strings are always
enclosed in quotation marks. {Enter} signifies the Enter key.

The following example shows a macro for writing a bulleted list. A complete
explanation follows the macro. After the explanation of the example, all the
macro functions, commands, and other elements are described in detail.

REM This macro is for creating bulleted lists.
Sub MAIN
AutoRestore(ON) : Insert(ON) : CmdTags (OFF)

SetHelpLevel (4) : HideDots (ON)

Key ("{Ctrl+O}FSHanging indent 1{Enter}")
Call Timesl2
ListLoop: Key (" +{Tab}")
PauseForInput ("{Enter}", ‘Enter the text.’)
IfException
NCM: Goto ListDone '‘User entered nothing
End IfException
Key ("{Enter}")
GoTo ListLoop
ListDone: Key ("{Ctrl+Q}{Del}")
Key ("{Ctrl+O}FP")
Stop
End Sub

Sub Timesl2

Key ("{Ctrl+P}=Times 12{Enter}")
Return

End Sub

This macro is composed of two subroutines, MAIN and Times12. MAIN has
the instructions for entering the bulleted list, and Times12 changes fonts.

The macro has two comments to remind the user what the macro is doing.

They are the REM line at the beginning of the macro and the comment “User
entered nothing,” which describes the situation in which that line takes effect.
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At the beginning of the MAIN subroutine are statements that use the
AutoRestore, Insert, CmdTags, SetHelpLevel, and HideDots functions to set
those five editor states.

The first Key function selects the Hanging Indent 1 paragraph style. Notice
that it contains all the keystrokes to choose this style, using the AOFS classic
command.

Next, the Call command runs the Times12 subroutine, which uses a Key state-
ment to change to the Times 12 font. After the font change, the Return com-
mand returns to MAIN. Instead of having this subroutine, you could put the
Key statement directly in the MAIN subroutine. However, you might want to
use this subroutine often in a macro, and it is convenient to be able to call it at
several places.

ListLoop is a label. A label marks a location so that you can go to it from else-
where in the subroutine to run the subsequent instructions. In this case, the
label allows a macro to return to the same location a number of times, creating
a “loop.” The Key statement types two spaces and then the bullet character and
atab. The PauseForinput function causes the macro to wait while the user
enters the text that goes next to the bullet, displaying the message Enter the text.
After entering the text, the user presses Enter, the input termination character.

If the user enters text and presses Enter, the IfException is ignored, and the next
Key statement presses Enter to go to the next line. Then the GoTo command
moves back to the ListLoop label to repeat the procedure for entering another
bullet and text.

The three lines beginning with IfException are an IfException clause. An
IfException clause tells the macro what to do if it does not receive the expected
user input. The IfException signifies the beginning of the clause and the
EndlfException signifies the end. NCM (No Cursor Movement) is the type of
exception. The NCM line tells the macro that if the user doesn’t enter anything
before pressing Enter (after the bullet character is entered), the macro should go
to the label InputDone. This clause provides the way to end the bulleted list
after the user enters the text for the last bullet.

All the indentation in the macro is optional; it is used to make the macro easy
to read. After the ListLoop label, the Key statement could be on the same line
or the next line, and all the following lines could begin at the left margin.
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At the ListDone label, there are two Key statements. The first deletes everything
on the line to the left of the cursor using the AQDel classic command. This
removes the last bullet that was inserted, for which there was no text. The last
statement reverts to the paragraph style that was in effect above the bulleted
list, using the AOFP classic command. At this point, the macro is finished,

and the user returns to editing.

Note that this macro uses classic commands. You can instead use the
pull-down menu Alt key combinations for the same commands.

Also note that you can put several statements on a single line by separating
statements with a colon (:). You can put spaces or tabs before and after the
colon, but they are not required. For example, the first two lines under

Sub MAIN in the example above contain five statements.

SUBROUTINES

The format of a subroutine is

Sub name
statements
End Sub

A subroutine name must begin with a letter and can contain up to 31 charac-
ters. The characters must be letters, digits, and the underline character, ( _).

Each macro must include the MAIN subroutine, and it is always executed first.
You can use additional subroutines to execute the same groups of statements in
several locations within a macro; you can enter a subroutine once and call it
each time it’s needed.

Each statement in a macro must be within a subroutine. Subroutines are
separate; a subroutine can call other subroutines, but one subroutine cannot be
within another in the text of a macro. Only the MAIN subroutine is executed
automatically; you must call any other subroutine to execute it.

Use the Call command to call the subroutine at each location you want to use
it. See “Commands” in this section.
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THE KEY( ) FUNCTION

The Key() function is the most important component of a macro. It specifies
the keystrokes that the macro enters. It is in the following format:

Key ("keystroke string")

The keystroke string must be enclosed in quotation marks. The string can
include text and special keys such as direction keys and WordStar commands.
A simple Key command with text only is

Key ("Sincerely yours,")
This command types the phrase Sincerely yours,.

Special keys are generally enclosed in braces, for example, {Enter} and {PgDn}.
A complete list of special keys is in Appendix C, “Macro Keystrokes.” Braces
are also used with key combinations, for example, {Alt+F1} and {Ctrl+P}. The
following Key command opens a document named KNOX.DOC:

Key ("{Alt+F}Dknox.doc{Enter}")
The following rules apply to special keys and key combinations:

= Upper- and lowercase letters are treated the same; for example, ALT is the
same as Alt.

= The caret symbol () can be used for the Ctrl key. Braces are not required
when this symbol is used. For example, AC (not enclosed in braces) is
equivalent to {Ctrl+C}.

® You can also enter control characters in a macro by pressing AP and then
the control character. For example, if you press APAC (hold down the
control key, press P and then C, then release the control key), AC appears
in the macro.

= For key combinations, you can use the Plus (+) sign, a space, or a hyphen
(-). For example, {Alt+F7}, {Alt F7}, and {Alt-F7} are equivalent.
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® An extended ASCII character can be entered by holding down the Alt key
and pressing the appropriate number keys on the numeric keypad. For
example, pressing Alt+156 puts the £ symbol in the macro.

= To enter an actual ", {, }, or #, double the character; type " ", {{, } }, or AA,

For any dialog box option with a check box, you can enter the commands to
move to that option, then enter a plus sign (+) for on, a minus sign (- ) for off,
or O for inherit (in paragraph styles). For example, the following Key( ) function
goes to the Alignment and Spacing dialog box using the 2OS classic command
and turns hyphenation on:

Key ( "A0Sh+" )

For more information about entering keystrokes, see Appendix C, “Macro
Keystrokes.”

OTHER FUNCTIONS

You can use several other functions besides the Key( ) function in WordStar
macros.

The following two functions allow the macro to pause for user input.

PauseForInput(“input termination key ”, 'message text’) Pauses macro execu-
tion so the user can enter text. The input termination key is the keystroke that
causes macro execution to resume. It must be enclosed in quotation marks.
The termination key is optional if you don’t include a message; if you don’t
specify a keystroke, Alt+Hyphen is used.

The message text is the message you want displayed while paused for input. It
must be enclosed in apostrophes. It is optional; if you don’t specify a message,
Paused. Press {ALT+-} to continue appears. To enter an apostrophe in the
message text, double the character; type ’ ’. If you include a message, the

input termination key is required in the PauseForlnput statement. If you use a
termination key other than the default, be sure to include a message that gives
the name of the key; otherwise, the person running the macro won’t know what
to do.

When you record a macro, Alt+Hyphen is used as the input termination key,
unless you change the default key using WSCHANGE (DCDB).
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PauseForKey() Pauses macro execution so the user can enter a single
keystroke (for example, Y or N). As soon as the user presses a key, macro
execution resumes.

The remaining functions set editing conditions for playing back the macro.
These editing conditions can affect how the commands in the macro work.
When you create a macro, it's best to use these functions unless you're sure the
editing conditions won’t affect macro execution. For example, if a macro is
written assuming that insert is on, and it is run in overtype mode, text could be
lost. If a macro is run at a different help level than it is written for, different
menus and dialog boxes may appear, and some of the commands in the macro
may not work correctly.

SetHelpLevel(1/2/3/4) Sets the help level in use for macro execution.
Insert(ON/OFF) Sets Insert mode to on or off for macro execution.

CmdTags(ON/OFF) Sets Command Tags display (or AOD) on or off for
macro execution.

HideDots(ON/OFF) Sets display of dot commands on or off for macro
execution.

ColMode(ON/OFF) Sets column block mode on or off for macro execution.

ColReplace(ON/OFF) Sets column replace mode on or off for macro
execution.

AutoRestore(ON/OFF) After the macro finishes running, restores the editor
conditions that were in effect when the macro started. This function is turned
on whenever a macro is recorded.

SingleStep(ON/OFF) Allows you to Single Step through a selected portion
of a macro.

When you record a macro, WordStar automatically inserts all these functions,
with the current settings, into the macro file. For example, recording a simple
macro to type Good morning! produces this macro file:
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Sub MAIN

SetHelpLevel (4)

Insert (ON)

CmdTags (OFF)

HideDots (ON)

ColMode (OFF)

ColReplace (OFF)

AutoRestore(ON)

Key ("Good morning! {Enter}")
End Sub

COMMANDS

You can use the following commands to control the flow of the macro
execution.

Call subroutine Executes the named subroutine in the current macro. When
the subroutine is completed, macro execution returns to the statement after the
Call statement, unless the subroutine includes the Stop command.

PlayMacro ‘macro’ Executes another macro. The macro name must be
enclosed in apostrophes. Include a path with the macro name if necessary.
Do not include the .WSM extension. To enter an apostrophe in the macro
name or path, double the character; type ’ ’. When the macro is completed,
execution returns to the statement after the PlayMacro statement in the original
macro, unless the other macro includes the Stop command.

ChainMacro ‘macro’ Executes another macro. The macro name must be
enclosed in apostrophes. Include a path with the macro name if necessary.
Do not include the .WSM extension. To enter an apostrophe in the macro
name or path, double the character; type ’ . When the macro is completed,
execution does not return to the original macro unless the ChainMacro com-
mand was invoked from a subroutine other than Main. In this case, execution
returns to the subroutine that called the subroutine containing the ChainMacro
command.

Stop Terminates the macro.
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Return Stops the current subroutine and returns to either the calling sub-
routine or the calling macro. If there is no calling subroutine or macro, the
macro is terminated.

GoTo label Goes to the named label, executes it, and continues from that
location. The label must be within the same subroutine as the GoTo command.

A label is a name that identifies a statement or location in a macro. You can
use a label to go to a specific location in the macro, and to repeat a set of
instructions in a loop. A label name must begin with a letter and can
contain up to 31 characters, which must be letters, digits, and the underline
character ( _). It must end with a colon ( :).

THE IFEXCEPTION CLAUSE

When you run the macro and it enters the keystrokes in the Key function, addi-
tional user input may be required before the macro can go on to the next func-
tion. For example, if you run a macro with the command to insert the file
JOE.DOC, Key(“{Alt+1}Fjoe.doc{Enter}”), and the JOE.DOC file doesn’t exist, a
message is displayed that requires user input. This is called an exception condi-
tion, and is handled using the IfException clause.

You can follow any Key command with an IfException clause. The IfException
clause handles these three types of exception conditions:

= User acknowledgement required (ACK) This condition occurs when
WordStar issues a message in response to a command issued by the macro,
and the user needs to press a key to acknowledge it. For example, after a
spelling check WordStar displays the number of words checked, and you
must press F10 or choose OK to continue.

= User clarification required (QRY) This condition occurs when WordStar
displays a dialog box in response to a command issued by the macro, and
the user needs to enter information or choose one of several options. For
example, if the macro inserts a file and gives a filename that doesn’t exist,
you need to type the correct filename or close the dialog box. When you
record a macro, ACK conditions are included when appropriate.
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® No cursor movement (NCM) If the macro repeats a cursor movement
command such as PgUp or PgDn indefinitely, this condition occurs when
the cursor reaches the beginning or end of the file or line. This condition
also occurs when no user input is received before the input termination key
is pressed after a PauseForlnput statement.

The IfException clause has the following format:

IfException
[ACK:
statements]
[QRY:
statements]
[NCM:
statements])
[DEF:
statements]

End IfException

The ACK, QRY, and NCM subclauses handle the three conditions described
above, and the DEF statement gives the default exception processing for

ACK and QRY conditions. At least one of these subclauses must be defined in
each IfException clause. The IfException, End IfException, and each subclause
must begin on a new line. You can use spaces or tabs to indent the subclauses
if you want.

If one of the three exception conditions occurs when the macro is run, the
IfException clause becomes active. If the subclause for the type of exception is
defined, WordStar executes the statements in that subclause. Otherwise, if the
exception is an ACK or QRY type and the DEF clause is defined, WordStar
executes the statements in the DEF subclause.

If no IfException clause is present in an ACK or QRY condition, or if an
appropriate subclause is not defined, the macro displays a message and waits
for user input for the dialog box or message on the screen. When appropriate
input is entered, the macro resumes. If no IfException clause is present in an
NCM condition, the condition is ignored and the macro proceeds.

When you record a macro, ACK and QRY (but not NCM) IfException clauses
are automatically inserted when exception conditions are encountered.
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The following example shows the use of ACK:

Sub Main
Key ("{Ctrl+Q}A")
Key ("wonderful{Tab}"})
Key ("excellent{Tab}")
Key ("MG")
Key ("{F10}")
IfException
ACK: Key ("{Esc}")
End IfException
End Sub

This macro uses the ~QA classic command. In the Find and Replace dialog
box, it instructs WordStar to replace “wonderful” with “excellent” using the

G (Entire File/Global) and M (Maintain Case) options. Then it issues the

F10 keystroke to close the dialog box and start the Find and Replace operation.
During this operation, the macro pauses at each instance of “wonderful” for the
user to press Y or N for the replacement. When the operation is complete, the
All replacements complete message triggers the ACK IfException, which sup-
plies the Esc keystroke to clear the message from the screen and resume editing.

The following example shows the use of QRY:

Sub Main

Key (" {Ctrl+P}=")

Key ("Times 10{Enter}")
IfException
QRY: Key ("{Esc}")

Key ("Courier 12{Enter}")

End IfException

End Sub

This macro uses the AP= classic command to choose a font. In the Font dialog
box, it chooses Times 10. If the Times 10 font isn’t available, the error message
triggers the QRY IfException, which supplies the Esc keystroke to remove the
message from the screen, then chooses the Courier 12 font.

For an example of using NCM, see “Macro Structure.”

T1P When a macro changes options in a dialog box, use separate Key
statements for each option. That way, you can use IfException clauses to
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correct problems with each option (for example, if the macro chooses a font or
paragraph style that isn’t available in the document).

COMMENTS

You can enter comments in a macro file in several ways:

= Use REM at the beginning of a line. All text following the. REM on that line is
comment. The REM can be preceded by tabs and spaces.

= Use an apostrophe () at the end of a statement line. All text following the
apostrophe on that line is comment.

= Start a comment anywhere in the macro with a slash and an asterisk ( /*),
and end it anywhere with an asterisk and a slash ( */). This type of comment
can be as many lines long as you like.

MERGE PRINT COMMANDS Pull-down: ALT + U, P

Enters commands and variable information in order to print personalized form
letters and other documents.

Merge printing is the process of inserting information into a document while it's
being printed. You can use merge printing for form letters, mailing labels,
invoices, contracts, reports, and any other standard document that requires you
to “fill in the blanks.”

When you print a document with merge print commands, be sure that the print
option Interpret Merge Variables is selected (the default). If you want to print
the document with the variable names showing in the text, and ignore the
merge print commands, clear this option.

WORKING WITH MERGE PRINTING

To merge print, you need a master document that contains both the text of the
document and the instructions for inserting the merged information. The
merged information can come from a data file such as a mailing list, or from the
keyboard at print time, or you can specify it at the beginning of the document.
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APPENDIX C

Macro
KEYSTROKES

This appendix describes the keystroke conventions used for the WordStar macro
system, and provides a table of all the keystrokes that the macro system recog-
nizes. For more information about macros, see “Macros” in “Utilities Menu.”

THE KEY( ) FUNCTION

The Key( ) macro function provides keystrokes to the application. The argument
of Key( ) is a keystroke string. For example, “Good Morning!{Enter}” is a valid
keystroke string, and to have it typed into WordStar you’d include the statement
KEY(“Good Morning!{Enter}”) in a macro. For guidelines for entering keystrokes
in the Key( ) function, see “The Macro Language” in “Macros” in “Editing Screen
Utilities Menu.”

TYPES OF KEYSTROKES

A keystroke is defined as the act of either pressing a single key or pressing a
number of keys at the same time. Keystrokes generate codes that are inter-
preted in one of two ways:
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= A keystroke can be an alphanumeric character, a punctuation mark, or
symbol such as A, ;, or . These are all called characters.

= A keystroke can be a command to perform an action such as delete a
character, move the cursor up one line, or start a new line. These
keystrokes are called application defined keystrokes.

The Key() function provides both types of keystrokes. The first type of
keystroke is represented in the keystroke string by simply entering the charac-
ter. The second type of keystroke is represented by a description as shown in
the table. Generally, the keystroke description is the same as the one that
appears on the key cap on the US keyboard. It is usually enclosed in braces
({}). (To enter an actual { or }, you double the character, for example, { { .)

A keyboard may contain more than one key that has the same general mean-
ing. To differentiate between keys with similar meanings, the following con-
ventions are used:

= Characters and descriptions enclosed in square brackets represent keys on
the numeric key pad, for example, [Enter]. Some of these keys are only
available on enhanced keyboards.

= Descriptions enclosed in parentheses represent the cursor and edit pad keys
on enhanced keyboards, for example, (UP) and (Del).

Combining these conventions leads to keystroke descriptions like {Enter},
{[Enter]}, and {(UP)}.

SHIFTED KEY DESCRIPTIONS

Keyboards have three types of keys that can be used with other keys, the Shift
key, the Control key (Ctrl), and the Alt key. Some non-US keyboards also have
a fourth key, the right Alt key (AltGr), which is used to generate additional
alphanumeric symbols. These keys are represented in macros enclosed in
braces with the accompanying key, for example, {Ctrl C}, {Alt A}, and {Shift F1}.

For alphabetic characters, punctuation marks, and other symbols, don’t indi-
cate the Shift key required to generate the keystroke; just enter the character as
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you normally would. For example, {Shift a} does not produce A. This is also
true for the AltGr shift key, which is used to generate characters, not instruc-
tions. For example, on a German keyboard, don’t represent / as {AltGr [3}.

I(EYSTROKES IN RECORDED MACROS

When a recorded macro is translated into a macro source file, keystrokes from
enhanced keyboards are translated into the equivalent keystrokes from unen-
hanced keyboards. For example, {(UP)} becomes {UP}. The same is true for
numbers and symbols on the numeric keypad; for example, {[1]} becomes 1.

If a specific keystroke is required, you can edit the macro and enter the
extended or numeric keypad description. When the macro is compiled, the
indicated scan code and character combination are used.

Note: When you execute a macro, it provides keystrokes to WordStar in the
same general way that the BIOS keyboard i/o service does. WordStar often per-
forms additional processing on a keystroke prior to acting on it. For example,

if you press AKAQ while recording (without taking your finger off of the control
key before pressing QQ), the macro file shows {CTRL KHCTRL Q}. During
playback, the WordStar editor takes the same action as if the source file con-
tained {CTRL K}Q.

I(EYSTROKES NOT IN THE TABLE

The table in this appendix shows the standard keystrokes based on the US key-
board in code page 437. Other keyboards and code pages can produce dif-
ferent keystroke codes. When a recorded macro is translated into a macro
source file, all recognizable codes are translated into US keyboard equivalents.
These equivalents may be particular keys or extended characters.

To enter a specific keystroke not in the table, enter it in {xxx,yyy} format,
where xxx is the high byte and yyy is the low byte of the decimal value of
the code.
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Any unrecognized keystroke code is translated into this same format when a
recording is translated into source code.

THE WORDSTAR MACRO US KEYSTROKE TABLE

The following table shows the valid keystrokes for WordStar macros.

The first column of the table shows the character or description associated
with each keystroke.

The second column shows the hexadecimal value of the code returned by
BIOS Interrupt 16H for each keystroke. This is called the keystroke code.
The high byte is usually called the scan code, and the low byte is usually
called the ASCII code. For text and punctuation keystrokes, the ASCII code
(low byte) is the number associated with the character.

The third column shows the decimal values of the high and low byte of the
keystroke code.

The fourth column indicates if the particular keystroke is available only on
an enhanced keyboard. It also shows keystrokes that are specific to
WordStar.

The last part of the table includes all the extended characters (those with
decimal codes 1 to 31 and 128 to 255). The characters shown in the table are
those displayed on the screen for the IBM symbol set for code page 437. (If
you're using a different code page, different characters are displayed on the
screen. The characters that are printed depend on the symbol set for the font
you use for printing.) You can enter extended characters in several ways. For
more information, see “Extended Character” in “Insert Menu.”



KEYSTROKE
DESCRIPTION

{BACKTAB}
{BKSP}
{DEL}
{(DEL)}
{DOWN}
{(DOWN)}
{END}
{(END)}
{ENTER}
{[ENTER]}
{ESC}
{HOME}
{(HOME)}
{INSERT}
{(INSERT)}
{LEFT}
{(LEFT)}
{PGDN}
{(PGDN)}
{PGUP}
{(PGUP)}
{RIGHT}
{(RIGHT)}
{TAB}
{(shy
{urP}
{cup)}
space

[*1}

OF
OF
53
53
50
50
4F
4F
1c
EO
01
47
47
52
52
4B
4B
51
51
49
49
4D
4D
OF
4c
48
48
39
02
28
04
05
06
08
28
0A
0B
09
37

00
08
00
EO
00
EO
00
EO
0D
0D
1B
00
EO
00
EO
00
EO
00
EO
00
EO
00
EO
09
00
00
EO
20
21
22
23
24
25
26
27
28
29
2A
2A
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015
014
083
083
080
080
079
079
028
224
001
071
071
082
082
075
075
081
081
073
073
077
077
015
076
072
072
057
002
040
004
005
006
008
040
010
011
009
055

000
008
000
224
000
224
000
224
013
013
027
000
224
000
224
000
224
000
224
000
224
000
224
009
000
000
224
032
033
034
035
036
037
038
039
040
041
042
042

Enhanced

Enhanced

Enhanced

Enhanced

Enhanced

Enhanced

Enhanced

Enhanced

Enhanced

Enhanced

Enhanced

Enhanced

keyboard
keyboard
keyboard

keyboard

keyboard
keyboard
keyboard
keyboard
keyboard
keyboard
keyboard

keyboard
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KEYSTROKE
DESCRIPTION HEX ECIMAL NOTE
+ 0D 2B 013 043
{[+1} 4E 2B 078 043
, 33 2C 051 044
- 0C 2D 012 045
{-1 4A 2D 074 045
. 34 2E 052 046
{[.]1} 53 2E 083 046
/ 35 2F 053 047
{[/1} E0 2F 224 047 Enhanced keyboard
: 27 3A 039 058
: 27 3B 039 059
< 33 3C 051 060
= 0D 3D 013 061
> 34 3E 052 062
? 35 3F 053 063
@ 03 40 003 064
[ 1A 5B 026 091
\ 2B 5C 043 092
] 1B 5D 027 093
A 07 5E 007 094
_ 0C 5F 012 095
‘ 29 60 041 096
{ 1A 7B 026 123
| 2B 7C 043 124
} 1B 7D 027 125
~ 29 7E 041 126
n/a 00 7F 000 127
0 0B 30 011 048
{[01} 52 30 082 048
1 02 31 002 049
{[11} 4F 31 079 049
2 03 32 003 050
{[2]1} 50 32 080 050
3 04 33 004 051
{31} 51 33 081 051
4 05 34 005 052
{[41} 4B 34 075 052
5 06 35 006 053
4C 35
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DESCRIPTION

6
{[61}
7
{71}
8
{81}
9
{[91}

D AOO0O T N<XE<C—HULVOXVO VOZIMNCrXANoLAITOGTMMOO®>

07
4D
08
47
09
48
0A
49
1E
30
2E
20
12
21
22
23
17
24
25
26
32
31
18
19
10
13
1F
14
16
2F
11
2D
15
2C
1E
30
2E
20
12

HEX

36
36
37
37
38
38
39
39
41
42
43
44
45
46
47
48
49
4A
4B
4c
4D
4E
4F
50
51
52
53
54
55
56
57
58
59
5A
61
62
63
64
65

DECIMAL

007
077
008
071
009
072
010
073
030
048
046
032
018
033
034
035
023
036
037
038
050
049
024
025
016
019
031
020
022
047
017
045
021
044
030
048
046
032
018

054
054
055
055
056
056
057
057
065
066
067
068
069
070
071
072
073
074
075
076
077
078
079
080
081
082
083
084
085
086
087
088
089
090
097
098
099
100
101

THE WORDSTAR MACRO US KEYSTROKE TABLE
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KEYSTROKE

DESCRIPTION HEX

K X E < C ctn 35S0 T O S 3 — X = TTAQ —h

N

{CTRL+BKSP}
{CTRL+BREAK}
{CTRL+DEL}
{CTRL+(DEL)}
{CTRL+DOWN}
{CTRL+(DOWN)}
{CTRL+END}
{CTRL+(END)}
{CTRL+ENTER}
{CTRL+[ENTER]}
{CTRL+HOME}
{CTRL+(HOME)}
{CTRL+INSERT}
{CTRL+(INSERT)}
{CTRL+LEFT}
{CTRL+(LEFT)}
{CTRL+PGDN}
{CTRL+(PGDN)}

21
22
23
17
24
25
26
32
31
18
19
10
13
1F
14
16
2F
11
2D
15
2C
OE
00
93
93
91
91
75
75
1C
EO
77
77
92
92
73
73
76
76

66
67
68
69
6A
68
6C
6D
6E
6F
70
71
72
73
74
75
76
77
78
79
7A
7F
00
00
EO
00
EO
00
EO
0A
0A
00
EO
00
EO
00
EO
00
EO

033
034
035
023
036
037
038
050
049
024
025
016
019
031
020
022
047
017
045
021
044
014
000
147
147
145
145
117
117
028
224
119
119
146
146
115
115
118
118

102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
127
000
000
224
000
224
000
224
010
010
000
224
000
224
000
224
000
224

NOTE

Enhanced
Enhanced
Enhanced
Enhanced
Enhanced
Enhanced
Enhanced
Enhanced
Enhanced

Enhanced

Enhanced

keyboard
keyboard
keyboard
keyboard
keyboard
keyboard
keyboard
keyboard
keyboard
keyboard

keyboard
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DESCRIPTION

{CTRL+PGUP}
{CTRL+(PGUP)}
{CTRL+PRTSC}
{CTRL+RIGHT}
{CTRL+(RIGHT)}
{CTRL+TAB}
{CTRL+UP}
{CTRL+(UP)}
{CTRL+"}
{CTRL+[*]}
{CTRL+[+]1}
{CTRL+,}
{CTRL+-}
{CTRL+[-1}
{CTRL+.}
{CTRL+/}
{CTRL+[/]1}
{CTRL+;}
{CTRL+[}
{CTRL+\}
{CTRL+]}
{CTRL+*}
{CTRL+0}
{CTRL+1}
{CTRL+2}
{CTRL+3}
{CTRL+4}
{CTRL+5}
{CTRL+[5]1}
{CTRL+6}
{CTRL+7}
{CTRL+8}
{CTRL+9}
{CTRL+A}
{CTRL+B}
{CTRL+C}
{CTRL+D}
{CTRL+E}
{CTRL+F}

HEX

84
84
72
74
74
94
8D
8D
C1
96
90
C3
0C
8E
C4
C5
95
c2
1A
28
1B
co
CD
Cé
03
C7
C8
C9
8F
07
CA
cB
cC
1E
30
2E
20
12
21

00
EO
00
00
EO
00
00
EO
00
00
00
00
1F
00
00
00
00
00
18
1C
1D
00
00
00
00
00
00
00
00
1E
00
00
00
01
02
03
04
05
06

D

132
132
114
116
116
148
141
141
193
150
144
195
012
142
196
197
149
194
026
043
027
192
205
198
003
199
200
201
143
007
202
203
204
030
048
046
032
018
033

AL

000
224
000
000
224
000
000
224
000
000
000
000
031
000
000
000
000
000
027
028
029
000
000
000
000
000
000
000
000
030
000
000
000
001
002
003
004
005
006

NOTE

Enhanced

Enhanced
Enhanced
Enhanced
Enhanced
WordStar
Enhanced
Enhanced
WordStar

Enhanced
WordStar
WordStar
Enhanced
WordStar

WordStar
WordStar
WordStar

WordStar
WordStar
WordStar
Enhanced

WordStar
WordStar
WordStar

keyboard

keyboard
keyboard
keyboard
keyboard
keystroke
keyboard
keyboard
keystroke

keyboard
keystroke
keystroke
keyboard
keystroke

keystroke
keystroke
keystroke

keystroke
keystroke
keystroke
keyboard

keystroke
keystroke
keystroke
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MACRO KEYSTROKES
KEYSTROKE
D P N HEX CIMAL NOTE
{CTRL+G} 22 07 034 007
{CTRL+H} 23 08 035 008
{CTRL+I} 17 09 023 009
{CTRL+J} 24 0A 036 010
{CTRL+K} 25 0B 037 011
{CTRL+L} 26 0C 038 012
{CTRL+M} 32 0D 050 013
{CTRL+N} 31 OE 049 014
{CTRL+0} 18 OF 024 015
{CTRL+P} 19 10 025 016
{CTRL+Q} 10 11 016 017
{CTRL+R} 13 12 019 018
{CTRL+S} 1F 13 031 019
{CTRL+T} 14 14 020 020
{CTRL+U} 16 15 022 021
{CTRL+V} 2F 16 047 022
{CTRL+W} 11 17 017 023
{CTRL+X} 2D 18 045 024
{CTRL+Y} 15 19 021 025
{CTRL+Z} 2C 1A 044 026
{ALT+BKSP} 0E 00 014 000 Enhanced keyboard
{ALT+(DEL)} A3 00 163 000 Enhanced keyboard
{ALT+(DOWN)} A0 00 160 000 Enhanced keyboard
{ALT+(END)} 9F 00 159 000 Enhanced keyboard
{ALT+ENTER} 1C 00 028 000 Enhanced keyboard
{ALT+[ENTER]} A6 00 166 000 Enhanced keyboard
{ALT+ESC} 01 00 001 000 Enhanced keyboard
{ALT+(HOME)} 97 00 151 000 Enhanced keyboard
{ALT+(INSERT)} A2 00 162 000 Enhanced keyboard
{ALT+(LEFT)} 98 00 155 000 Enhanced keyboard
{ALT+(PGDN)} Al 00 161 000 Enhanced keyboard
{ALT+(PGUP)} 99 00 153 000 Enhanced keyboard
{ALT+(RIGHT)} 9D 00 157 000 Enhanced keyboard
{ALT+TAB} A5 00 165 000 Enhanced keyboard
{ALT+(UP)} 98 00 152 000 Enhanced keyboard
{ALT+"} 28 00 040 000 Enhanced keyboard
{ALT+[*]} 37 00 055 000 Enhanced keyboard
{ALT+[+]} 4E 00 078 000 Enhanced keyboard
{ALT+,} 33 00 051 000 Enhanced keyboard




THE WORDSTAR MACRO US KEYSTROKE TABLE

KEYSTROKE

DESCRIPTION HEX DECIMAL NOTE

{ALT+-} 82 00 130 000

{ALT+[-1} 4A 00 074 000 Enhanced keyboard
{ALT+.} 34 00 052 000 Enhanced keyboard
{ALT+/} 35 00 053 000 Enhanced keyboard
{ALT+[/1} A4 00 164 000 Enhanced keyboard
{ALT+;} 27 00 039 000 Enhanced keyboard
{ALT+=} 83 00 131 000

{ALT+[} 1A 00 026 000 Enhanced keyboard
{ALT+\} 2B 00 043 000 Enhanced keyboard
{ALT+]} 1B 00 027 000 Enhanced keyboard
{ALT+} 29 00 041 000 Enhanced keyboard
{ALT+0} 81 00 129 000

{ALT+1} 78 00 120 000

{ALT+2} 79 00 121 000

{ALT+3} 7A 00 122 000

{ALT+4} 78 00 123 000

{ALT+5} 7C 00 124 000

{ALT+6} 7D 00 125 000

{ALT+7} 7E 00 126 000

{ALT+8} 7F 00 127 000

{ALT+9} 80 00 128 000

{ALT+A} 1E 00 030 000

{ALT+B} 30 00 048 000

{ALT+C} 2E 00 046 000

{ALT+D} 20 00 032 000

{ALT+E} 12 00 018 000

{ALT+F} 21 00 033 000

{ALT+G} 22 00 034 000

{ALT+H} 23 00 035 000

{ALT+I} 17 00 023 000

{ALT+J} 24 00 036 000

{ALT+K} 25 00 037 000

{ALT+L} 26 00 038 000

{ALT+M} 32 00 050 000

{ALT+N} 31 00 049 000

{ALT+0} 18 00 024 000

{ALT+P} 19 00 025 000

{ALT+Q} 10 00 016 000

{ALT+R} 13 00 019 000




MACRO KEYSTROKES

KEYSTROKE

DESCRIPTION HEX
{ALT+S} 1F 00
{ALT+T} 14 00
{ALT+U} 16 00
{ALT+V} 2F 00
{ALT+W} 11 00
{ALT+X} 2D 00
{ALT+Y} 15 00
{ALT+Z} 2C 00
{F1} 3B 00
{F2} 3C 00
{F3} 3D 00
{F4} 3E 00
{F5} 3F 00
{F6} 40 00
{F7} 41 00
{F8} 42 00
{F9} 43 00
{F10} 44 00
{F11} 85 00
{F12} 86 00
{SHIFT+F1} 54 00
{SHIFT+F2} 55 00
{SHIFT+F3} 56 00
{SHIFT+F4} 57 00
{SHIFT+F5} 58 00
{SHIFT+F6} 59 00
{SHIFT+F7} 5A 00
{SHIFT+F8} 5B 00
{SHIFT+F9} 5C 00
{SHIFT+F10} 5D 00
{SHIFT+F11} 87 00
{SHIFT+F12} 88 00
{CTRL+F1} 5E 00
{CTRL+F2} 5F 00
{CTRL+F3} 60 00
{CTRL+F4} 61 00
{CTRL+F5} 62 00
{CTRL+F6} 63 00
{CTRL+F7} 64 00

031
020
022
047
017
045
021
044
059
060
061
062
063
064
065
066
067
068
133
134
084
085
086
087
088
089
090
091
092
093
135
136
094
095
096
097
098
099
100

000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000

NOTE

Enhanced keyboard
Enhanced keyboard

Enhanced keyboard
Enhanced keyboard




KEYSTROKE

DESCRIPTION HEX
{CTRL+F8} 65 00
{CTRL+F9} 66 00
{CTRL+F10} 67 00
{CTRL+F11} 89 00
{CTRL+F12} 8A 00
{ALT+F1} 68 00
{ALT+F2} 69 00
{ALT+F3} 6A 00
{ALT+F4} 68 00
{ALT+F5} 6C 00
{ALT+F6} 6D 00
[ALT+F7} 6E 00
{ALT+F8} 6F 00
{ALT+F9} 70 00
{ALT+F10} 71 00
{ALT+F11} 88 00
{ALT+F12} 8C 00
EXTENDED CHARACTERS
CHARACTER HEX
© 00 01
® 00 02
v 00 03
. 00 04
& 00 05
'S 00 06
. 00 07
a 00 08
o) 00 09
O] 00 0A
3 00 OB
? 00 0C
d 00 0D
3 00 OE
* 00 OF
> 00 10
< 00 11
: 00 12
1] 00 13
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101
102
103
137
138
104
105
106
107
108
109
110
111
112
113
139
140

DEC

000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000

000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000

001
002
003
004
005
006
007
008
009
010
011
012
013
014
015
016
017
018
019

Enhanced keyboard
Enhanced keyboard

Enhanced keyboard
Enhanced keyboard




MACRO KEYSTROKES
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00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00

HEX

14
15
16
17
18
19
1A
1B
1C
1D
1E
1F
80
81
82
83
84
85
86
87
88
89
8A
8B
8C
8D
8E
8F
90
91
92
93
94
95
96
97
98
99
9A

000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000

DECIMAL

020
021
022
023
024
025

026
027
028
029
030
031
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154

NOTE
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00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00

HEX

98
9C
9D
9E
9F
A0
Al
A2
A3
A4
A5
A6
A7
A8
A9
AA
AB
AC
AD
AE
AF
BO
B1
B2
B3
B4
B5
B6
B7
B8
B9
BA
BB
BC
BD
BE
BF
co
C1
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DECIMAL

000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000

155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193

NOTE




MACRO KEYSTROKES

F=-rr+ | +—4
-

I==

CHh==g m o~ == A

GAFTAMA TR Hem™E BN~

HEX

00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00

C2
C3
C4
C5
Cé6
c7
c8
c9
CA
CB
cc
CD
CE
CF
DO
D1
D2
D3
D4
D5
D6
D7
D8
D9
DA
DB
DC
DD
DE
DF
EO
El
E2
E3
E4
ES
E6
E7
E8

DECIMAL

000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000

194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232

NOTE
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HEX

00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00
00

E9
EA
EB
EC
ED
EE
EF
FO
F1
F2
F3
F4
F5
F6
F7
F8
F9
FA
FB
FC
FD
FE
FF
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000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000
000

233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255



APPENDIX D

FuNcTION KEYS
AND OTHER
MACROS

You can use the function keys, which are usually labeled F1, F2, F3, and so on,
to execute the most frequently used WordStar commands with a single
keystroke.

Each function key is set to issue four different commands, depending on
whether you use the function key by itself or while holding down one of these
keys: Shift, Ctrl, or Alt.

The commands issued by the function keys are preprogrammed macros created
with the WordStar macro commands. You can change the function key assign-
ments by choosing Utilities=>Macros and then Record, Edit/Create, or Rename,
or using the classic command AMR, AMD, or *ME. For information about
working with macros, see “Macros” in “Ultilities.”

All the function key assignments are shown in the following table.
In addition to the function keys, several other preprogrammed macros are sup-

plied with WordStar. These keys are also listed in the table. Several other
macros that are not included in the table are also preprogrammed as examples.



FUNCTION KEYS AND OTHER MACROS

FUNCTION
KEY

(F1)

F1
Shift+F1
Ctrl+F1
Alt+F1

(F2)

F2
Shift+F2
Ctrl+F2
Alt+F2

(F3)

F3
Shift+F3
Ctrl+F3
Alt+F3

F4
Shift+F4
Ctrl+F4
Alt+F4

()

F5

Shift+F5

Ctrl+F5
Alt+F5

F6
Shift+F6
Ctrl+F6
Alt+F6

F7

Shift+F7
Ctrl+F7
Alt+F7

CLASSIC
COMMAND

F1
AOD
AQF
l

AU
AOC
AQA

APS
~AQRMQL
AL

r

APB
AQN
AQI

AY

AKY
AQS.LMAN
L

AT

AKH
AQS.RMAN
J

ABI\QP

AKV
AQS.PM6.
.

PULL-DOWN COMMAND
OR FUNCTION

Help =>Help (this key cannot be reprogrammed)

View=>Command Tags
Edit=Find
Inserts box-drawing character

Edit=Undo

Layout=>Center Line
Edit=>Find and Replace
Inserts box-drawing character

Style=>Underline
Utilities=>Spelling Check Global
Edit=>Next Find

Inserts box-drawing character

Style=>Bold

Utilities=>Spelling Check Other—>Word
Edit=>Go to Page

Inserts box-drawing character

Edit=>Delete=>Line
Edit=>Delete=>Block

Inserts .Im command on its own line
Inserts box-drawing character

Edit=>Delete=>Word

View=>Block Highlighting

Inserts .rm command on its own line
Inserts box-drawing character

Utilities—>Reformat=>Paragraph, then

Edit =>Go to Other=>Previous Position
Edit=>Move=>Block
Inserts .pm6 command and a carriage return
Inserts box-drawing character




FUNCTION
KEY

F8

Shift+F8
Ctrl+F8
Alt+F8

F9
Shift+F9
Ctrl+F9
Alt+F9

F10

Shift+F10
Ctrl+F10
Alt+F10

Alt+0
Alt+1
Alt+D
Alt+M
Alt+T
Alt+B
Alt+N

CLASSIC
COMMAND

AQSMOO

AKC
AQS.PA
L

AKS
AKB
AQS

AKD

AKK
AQD

AQOFS
AQP
n/a
n/a
n/a
n/a
n/a

FUNCTION KEYS AND OTHER MACROS

PULL-DOWN COMMAND
OR FUNCTION

Inserts the .rr command with current ruler line
settings above the current line

Edit=>Copy=>Block

Insert=>Page Break

Inserts box-drawing character

File=>Save

Edit=>Mark Block Beginning

Moves the cursor to beginning of the line
Inserts box-drawing character

File=>Save and Close

(this key cannot be reprogrammed)
Edit=>Mark Block End
Moves the cursor to the end of the line
Inserts box-drawing character

Style=>Select Paragraph Style
View=>Preview

Find next compiler error for editing macros
Enters a memo boilerplate

Enters a To Do list boilerplate

Bulleted List

Numbered list





